DYNAMIC INTERACTIVE EXCEL TEMPLATES
FOR THE MATH CLASSROOM

Mariano (Rod) Rodrigues
University of Phoenix Online
rod@Excel4Math.com

Interactive environments in the classroom provide us with an exciting way to explore concepts. Instead of looking at one or two examples, students can watch as you slide through hundreds of examples. Excel is a very cost-effective environment for developing tools for the classroom.

What does a user/designer need?

- The user/designer needs to have access to Excel 2003 or later.

What does a user need to know?

- how to type numbers into cells.
- how to view the formula that generates the cell
- how to operate “sliders.”
- how to enable macros.
- in a few cases how to allow self-referenced cells
- how to remove protections, if they want to copy material to the clipboard

What does a designer need to know?

- how to build a table and a chart that rely on a parameter.
- how to translate a symbolic equation into a dynamic table
- how to dynamically control the parameter(s)
  - Name a cell
  - Create a slider
  - Indirectly control the named cell
- how to fix the scale of a chart for better comparisons
- optionally, how to protect cells and sheets.
Notes to the user

You do not need to “learn Excel” in order to use templates designed using Excel. The situation is similar, almost, to reading a document prepared, say, with Word. You do not need to learn Word in order to read the document. In the case of a Dynamic Excel template, you simply need to know how to type numbers and use sliders. And if you are prompted to enable macros, you should click on the YES button.

Typing Numbers

Excel is organized into rows and columns, and each location where you can type is called a cell. If you click anywhere in a spreadsheet, the cursor will be positioned in a cell. The cell will be labeled according to the column and row. Columns are labeled with letters, and rows will be labeled with numbers.

```
<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
```

Notice that just above the spreadsheet area, to the left, Excel will tell you which cell you are in. To the right of the cell address, you see the number as typed. In the actual cell, you see the number, formatted with two decimal places (though in practice it could be formatted in other ways).

Formulas can also appear in cells.

```
<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td></td>
<td>=78+9</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td></td>
<td>167.00</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
```

When a formula is typed (preceded by an equals sign) you can see the formula typed, complete with the equals sign, on the top line. The ANSWER appears visibly in the cell.

Using Sliders

Dynamic Interactives frequently employ sliders. When you click on sections of a slider, they will have an impact on a cell somewhere else, usually nearby.
Clicking on the < will usually decrease the number.
Clicking on the > will usually increase the number.
You can click and drag the button in between to cause rapid jumps in the values, making them larger or smaller, depending on whether you drag to the right or the left.

**Enabling Macros**

*In Excel 2003*
Follow the menu options **Tools>Macro>Security** and set it to medium or low.

*In Excel 2007*
If macros are disabled, you will have a security warning (a security shield) just above the spreadsheet area.

![Security Warning](Image)

To the right of it, click on Options and select **Enable this content**.

**Removing Spreadsheet Protection**

When a designer takes the time to construct a complex template, with lots of formulas, he/she may “turn protection on” in order to prevent you from inadvertently destroying the cells containing the formulas. If protection is on, you may not be able to see the formulas in place, you will not be able to select the cells containing formulas, and you may not be able to select a chart in order to copy it to the clipboard. You can remove that protection, but it is wise that you save it to your computer with a new name, thereby preserving the original template.

To remove protection in Excel 2003, follow the menu options

**Tools>Protection>Unprotect**

To remove protection in Excel 2007, click on the Review Tab

![Review Tab](Image)
If the sheet is protected, you will find a button to Unprotect the sheet.

**Notes to the designer**

Designers need to know how to generate tables and charts. I do not deal with that basic level here, but I do have materials available.

To help make such things dynamically respond, the designer needs to understand the difference between relative and absolute cell references. When you copy a cell that contains relative cell references, the new cells will be different from the original, in a literal sense, but the relationships to the named cells will be relatively preserved. If the original cell said “multiply the cell to the left by 3” then that rule will be copied.

An absolute cell reference does not change when copied. To make a cell reference like B3 absolute, we use dollar signs. $B$3 is an absolute reference. When a formula includes such a reference, then that part of the formula will not change as it is copied. We can turn that to our advantage.

**Naming a cell**

Position your cursor in a cell like C1.

Click into the cell address area and type the word **Slope**. It is important that when done you **press the enter button**. This is a shortcut for naming a cell. Naming a cell means it can then be absolutely referenced by using the name of the cell. For math, this will amount to giving us the ability to name parameters that control the actions and appearance of the spreadsheet.

To see how this works, follow these steps.

1. Name cell C1 using **Slope** as the name and enter the number 4 into cell C1.
2. Into cell A4 type the number -3
3. Into cell B4 enter the formula **=Slope*A4+6**
4. Into cell A5 enter the formula **=A4+.5**
5. Copy cell B4 to B5. You will see that Slope has been copied literally, while the A4 will have been copied relatively, and it will be A5. So Slope was copied absolutely and A4 was copied relatively.
6. Highlight cells B5 and A5, selecting both. There will be a little black square in the lower right hand corned. Click on that and drag it down. This is called a **data fill**.
7. In Excel 2003, use Ctrl-` (accent grave, the upper left corner of the keyboard). This reveals all formulas. The result:

<p>| | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>4</td>
<td>1</td>
<td>=Slope*A4+6</td>
</tr>
<tr>
<td>5</td>
<td>=A4+0.5</td>
<td>=Slope*A5+6</td>
</tr>
<tr>
<td>6</td>
<td>=A5+0.5</td>
<td>=Slope*A6+6</td>
</tr>
<tr>
<td>7</td>
<td>=A6+0.5</td>
<td>=Slope*A7+6</td>
</tr>
<tr>
<td>8</td>
<td>=A7+0.5</td>
<td>=Slope*A8+6</td>
</tr>
<tr>
<td>9</td>
<td>=A8+0.5</td>
<td>=Slope*A9+6</td>
</tr>
<tr>
<td>10</td>
<td>=A9+0.5</td>
<td>=Slope*A10+6</td>
</tr>
<tr>
<td>11</td>
<td>=A10+0.5</td>
<td>=Slope*A11+6</td>
</tr>
<tr>
<td>12</td>
<td>=A11+0.5</td>
<td>=Slope*A12+6</td>
</tr>
<tr>
<td>13</td>
<td>=A12+0.5</td>
<td>=Slope*A13+6</td>
</tr>
<tr>
<td>14</td>
<td>=A13+0.5</td>
<td>=Slope*A14+6</td>
</tr>
</tbody>
</table>

Note that the absolute reference can be turned to advantage. The Slope parameter is preserved. Naming a cell allows us to construct situations that reveal the impact of a parameter. To see this, you can simply keep changing the value in cell C1.

Save the above resultant spreadsheet: call it **Lines.xls**

**Sliders**

In order to place sliders on your spreadsheet, you need to take some action that will be required just once.
In Excel 2003, click on **View>Toolbars>Forms**

You may get a floating set of tools – if so you can dock it in your toolbar.

Undocked, you will have

The arrow here points to the button for the slider control.

In Excel 2007, you will need to install the Developer Tab. Click on the icon at the upper left corner of the Excel 2007 screen.
In the resulting dialog box, locate the Excel Options button (lower right).

Click the Popular link and check the box to show Developer tab in the Ribbon. Then click the OK button.

When you are back in Excel, you will now see the Developer tab.
In the Developer Ribbon, click on Insert.

The slider (Scroll Bar Form Control) is the third item in the second row.

In both versions of Excel, you click on the slider button, then locate inside of the spreadsheet, click-and-drag to drop a slider bar into place.. Click on it. Then anywhere in the spreadsheet area, click and drag to the size you wish. Here I have made it the size of one cell:

Right click on the slider and select Form Control.

Right-Click on the slider and select Format Control. Almost all of the items need to be set (see below).
Current value will be the default start-up value. As with all the numbers entered in this control must be whole numbers.

Minimum and Maximum values are self-explanatory.

Incremental Change: When you click the little arrow on the control, the value will jump by this much. Note: This can be a whole number. If you want to cause the visible cell to change by fractional values, you need to add some work.

Cell link is the cell that will change when this control is clicked. If you want to have this control a named cell, you can enter the name there. For example, if you want that to control the cell named Slope, you can enter the word Slope.

**Indirect control of the visible cell**

What if you want the visible numbers controlled by the slider to increment by fractional amounts? Suppose you want each click to increment the number by 0.25. We will produce a slight of hand.

First, let the Form Control point to a Cell link that is well off-screen, say cell $B$1. Let’s further suppose that the cell that the user sees is cell G8. Into cell G8, enter the formula “=BA1/4”

In the form control, set the increment to 1.
Then the visible number will NOT be the number controlled by the Form Control. Yet it will change whenever the form control is clicked, using whatever formula you wish. You can experiment with Minimum, Maximum, Increment and cell formulas to produce any range and increments you like.

**Fixing the scale of a chart/graph**

When you create a chart in Excel, the program will “decide” for you what the horizontal and vertical scale should be. If you change the y-values, Excel may change the scale to fit new values in the table. This gets in the way if you are rapidly changing parameters – in fact, this makes it possible to change the parameter and see little visual evidence of the change. To fix this, it is best to force Excel NOT to change the scale. You do this by manually setting the scale, using limits that you find acceptable for the range of items you want to study.

Create a chart. Then double-click on the y-axis. Select the Scale tab.

By default, the options are set to Auto. If you manually change any of the items, the Auto checkbox will be unchecked automatically, Or you can unclick the Auto.
Protecting formula cells and sheets

In either version of Excel, protection will automatically lock ALL cells by default. So you have to start by UNlocking any cells where you expect the user to type a number, and any cells that are changed when a user clicks on a slider.

Select the range of cells to unlock, right-click on the cells selected, and choose the Protection tab. Unclick the Locked option.

Once you have unlocked cells that MUST be allowed to change through user action, you need to enable protection of the sheet.

In Excel 2003:

Tools>Protection>Protect Sheet
Continue below

In Excel 2007:
Use the Review Tab and click on the Protect Sheet button.

In either version you will get this screen:

When protecting a sheet, you will be prompted with checkboxes to select those items that you want the user to be able to select. If you are expecting the user to type a number, then you must allow the user to select the cell (choose Select unlocked cells).